View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0021467LazarusIDEpublic2012-03-11 23:412012-03-12 22:44
ReporterGustavo Carreno 
Assigned ToZeljan Rikalo 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.9.30.4Product Build 
Target VersionFixed in Version 
Summary0021467: Tabs unreachable or content unreachable.
DescriptionI'm using Lazarus "amd64 0.9.30.4RC3" and "fpc 2.6.0 amd64" on "Ubuntu 11.04 amd64".

If I start the IDE and click immediately on tabs, I can't get to the content of such tab.

If I start the IDE and click on any content of a tab, I cannot reach the tabs.

I have to restart the IDE to proceed.

It's been like this for quite a while. I think since ever. Could it be some Unity problem?
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

- Relationships

-  Notes
(0057495)
Zeljan Rikalo (developer)
2012-03-12 08:11

Please try export LIBOVERLAY_SCROLLBAR=0 in terminal and then start lazarus from that terminal. Then give feedback here. If it works with that env setting then it's because of unity.
(0057501)
Zeljan Rikalo (developer)
2012-03-12 12:48

maybe this can help
http://www.webupd8.org/2012/03/unsettings-tool-to-disable-global-menu.html [^]
(0057511)
Gustavo Carreno (reporter)
2012-03-12 18:47

I've been using MyUnity to tweak Unity, but I've never had to mess around the Window Overlays and ScrollBars. Looks like MyUnity does not tweak that.

Will give a try with Unsettings and then report.
(0057512)
Gustavo Carreno (reporter)
2012-03-12 18:51

And again, forgot to give link for MyUnity, sorry!!

https://launchpad.net/myunity [^]
http://www.uielinux.org/myunity/ [^]
(0057517)
Gustavo Carreno (reporter)
2012-03-12 19:41

Ok, all sorted with unsettings. But it doesn't work when launched from command line, only from launcher.

I'm considering this issue solved.
(0057521)
Zeljan Rikalo (developer)
2012-03-12 20:23
edited on: 2012-03-12 20:25

You can add export LIBOVERLAY_SCROLLBAR=0 into your $HOME/.bashrc so it'll work whenever you log in. Please close.


- Issue History
Date Modified Username Field Change
2012-03-11 23:41 Gustavo Carreno New Issue
2012-03-11 23:41 Gustavo Carreno Widgetset => GTK 2
2012-03-12 08:11 Zeljan Rikalo LazTarget => -
2012-03-12 08:11 Zeljan Rikalo Note Added: 0057495
2012-03-12 08:11 Zeljan Rikalo Status new => feedback
2012-03-12 12:48 Zeljan Rikalo Note Added: 0057501
2012-03-12 18:47 Gustavo Carreno Note Added: 0057511
2012-03-12 18:51 Gustavo Carreno Note Added: 0057512
2012-03-12 19:41 Gustavo Carreno Note Added: 0057517
2012-03-12 20:23 Zeljan Rikalo Status feedback => resolved
2012-03-12 20:23 Zeljan Rikalo Resolution open => fixed
2012-03-12 20:23 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-03-12 20:23 Zeljan Rikalo Note Added: 0057521
2012-03-12 20:25 Zeljan Rikalo Note Edited: 0057521
2012-03-12 22:44 Gustavo Carreno Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker