View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0021465LazarusIDEpublic2012-03-11 23:372012-03-12 22:46
ReporterGustavo Carreno 
Assigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version0.9.30.4Product Build 
Target VersionFixed in Version 
Summary0021465: amd64 gtk2 bins having pager problems
DescriptionI'm using Lazarus "amd64 0.9.30.4RC3" and "fpc 2.6.0 amd64" on "Ubuntu 11.04 amd64".

All my executables give the following error, here expressed from the lazarus bin itself:
---------------------------->8----------------------------
gcarreno@BatchAMD:~$ UBUNTU_MENUPROXY= startlazarus
TLazarusManager.Run DefaultDir="/usr/lib/lazarus/0.9.30.4/" CustomDir="/home/gcarreno/.lazarus/bin/"
TLazarusManager.Run starting /home/gcarreno/.lazarus/bin/lazarus ...
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/home/gcarreno/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
TMainIDE.DoLoadLFM Creating designer for hidden component of /home/gcarreno/LazComponents/lnet/examples/visual/smtp/logs.pas
TMainIDE.DoOpenProjectFile FormLogs:TFormLogs TDesigner
LAZARUS END - cleaning up ...
[TMainIDE.Destroy] A
[TMainIDE.Destroy] B -> inherited Destroy... TMainIDE
[TMainIDE.Destroy] END
[CRITICAL] os_pager_hide: assertion `OS_IS_PAGER (pager)' failed

(lazarus:16701): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed
[CRITICAL] os_pager_set_parent: assertion `OS_IS_PAGER (pager)' failed
[CRITICAL] os_pager_hide: assertion `OS_IS_PAGER (pager)' failed

(lazarus:16701): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed
[CRITICAL] os_pager_set_parent: assertion `OS_IS_PAGER (pager)' failed
[CRITICAL] os_pager_hide: assertion `OS_IS_PAGER (pager)' failed

(startlazarus:16697): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed
[CRITICAL] os_pager_set_parent: assertion `OS_IS_PAGER (pager)' failed
gcarreno@BatchAMD:~$
---------------------------->8----------------------------
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

- Relationships

-  Notes
(0057496)
Zeljan Rikalo (developer)
2012-03-12 08:12

Why UBUNTU_MENUPROXY= ?
export LIBOVERLAY_SCROLLBAR = 0
startlazarus
should work.
(0057509)
Gustavo Carreno (reporter)
2012-03-12 18:23

Used "UBUNTU_MENUPROXY" just because it was mentioned in the wiki in relationship with Unity, and because I prefer the menu on the main window. It does not affect the outcome.

Let me try the LIBOVERLAY_SCROLLBAR and I'll report.
(0057510)
Gustavo Carreno (reporter)
2012-03-12 18:29

Sorry, forgot to mention the wiki link : http://wiki.freepascal.org/Lazarus_release_version_for_Ubuntu [^]

I've tried it with liboverlay and it works fine.

Now is there a way to automate this in another way?
Well, besides having it under .bashrc or .profile, or similar?
(0057516)
Gustavo Carreno (reporter)
2012-03-12 19:39

Ok, last report:

using both these:
---------------------------->8----------------------------
gcarreno@BatchAMD:~$ UBUNTU_MENUPROXY= LIBOVERLAY_SCROLLBAR= startlazarus
TLazarusManager.Run DefaultDir="/usr/lib/lazarus/0.9.30.4/" CustomDir="/home/gcarreno/.lazarus/bin/"
TLazarusManager.Run starting /home/gcarreno/.lazarus/bin/lazarus ...
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/home/gcarreno/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
TMainIDE.DoLoadLFM Creating designer for hidden component of /home/gcarreno/LazComponents/lnet/examples/visual/smtp/logs.pas
TMainIDE.DoOpenProjectFile FormLogs:TFormLogs TDesigner
TMainIDE.DoOpenProjectFile frmMain:TfrmMain TDesigner
LAZARUS END - cleaning up ...
[TMainIDE.Destroy] A
[TMainIDE.Destroy] B -> inherited Destroy... TMainIDE
[TMainIDE.Destroy] END
gcarreno@BatchAMD:~$
---------------------------->8----------------------------

So we do not have any issue with the Overlay Scrollbars and I've finally got rid of the global menus.

Looks like Unsettings does not make the global menu go away. Odd.

So in regards to my issue, I think it's solved.

Now, are you going to fix this with code? Or is it something to do with the GTK2 lib?
(0057518)
Gustavo Carreno (reporter)
2012-03-12 19:43

NOW, last report :)

Launching from command line unsettings has no result.
Calling the way I stated on my previous note will emulate what unsettings has setted.

When called from launcher, both global menu and Overlay scroll bars are non-existant and the issue goes away.

Many thanks.
(0057522)
Zeljan Rikalo (developer)
2012-03-12 20:24

Liboverlay problem, please close.

- Issue History
Date Modified Username Field Change
2012-03-11 23:37 Gustavo Carreno New Issue
2012-03-11 23:37 Gustavo Carreno Widgetset => GTK 2
2012-03-12 08:12 Zeljan Rikalo Note Added: 0057496
2012-03-12 18:23 Gustavo Carreno Note Added: 0057509
2012-03-12 18:29 Gustavo Carreno Note Added: 0057510
2012-03-12 19:39 Gustavo Carreno Note Added: 0057516
2012-03-12 19:43 Gustavo Carreno Note Added: 0057518
2012-03-12 20:24 Zeljan Rikalo LazTarget => -
2012-03-12 20:24 Zeljan Rikalo Status new => resolved
2012-03-12 20:24 Zeljan Rikalo Resolution open => no change required
2012-03-12 20:24 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-03-12 20:24 Zeljan Rikalo Note Added: 0057522
2012-03-12 22:46 Gustavo Carreno Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker