View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0020520LazarusLCLpublic2011-10-19 16:552012-01-17 10:19
ReporterFred 
Assigned ToZeljan Rikalo 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionnot fixable 
PlatformOSOS Version
Product Version0.9.30.1 (SVN)Product Build 
Target VersionFixed in Version 
Summary0020520: Ubuntu 11.10 vs. Lazarus apps
DescriptionLazarus applications have problems to run on latest Ubuntu 11.10 where the reason is new Taskbar menu and scrollbar.

To get application running like on older Ubuntu we have to remove some functionality from Ubuntu using by this command:

sudo apt-get remove appmenu-gtk3 appmenu-gtk appmenu-qt
liboverlay-scrollbar-0.2-0
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

- Relationships
has duplicate 0020679resolvedJuha Manninen Packages TScrollbar causes TWinControl.WMSize loop with Ubuntu 11.10 
related to 0020618resolvedZeljan Rikalo Lazarus Button click and key presses go to wrong window inside Lazarus 

-  Notes
(0053173)
Vincent Snijders (manager)
2011-10-19 19:03

Fortunately there is a workaround available.
(0053884)
Fred (reporter)
2011-11-07 11:02
edited on: 2011-11-07 11:38

Can't we get any solution for this problem, because it makes a big problem for all customers moved to U11.10.

(0053887)
Zeljan Rikalo (developer)
2011-11-07 12:23
edited on: 2011-11-07 12:32

No. We cannot do anything with gtk2 atm. Only solution is to export variable which is mentioned around (form and even on issue tracker) ... don't know exact name of variable but it have OVERLAY in it's name. IMO, this should be closed, since this have nothing to do with lazarus and gtk2.
@Fred: proposal for you: find some uniqueness which provides ubuntu 11.10 in X11 atoms, so if such atom is presented, we can add that bash variable into widgetset creation.

UPDATE: export LIBOVERLAY_SCROLLBAR=0 and then start your app.

(0053893)
cobines (reporter)
2011-11-07 15:46

Can this variable be always set by Lazarus? I don't know if this might cause any problems on non-Ubuntu. We simply set this variable at start of our application always.

Maybe a check via lsb_release or /etc/lsb-release can be made. But I don't know if it is installed by default in Ubuntu.
(0053896)
Zeljan Rikalo (developer)
2011-11-07 16:31

cobines, it's not nice to export such variable by default. I don't know what implications it can cause with other desktops (and don't know what liboverlay does at all) ... so best could be to find out from env or from xatoms some unique data for unity and then it can be easily exported.
(0054445)
Fred (reporter)
2011-11-25 11:26

@Zeljan:

Do you mean that it is possible to export any variable out of our exe file. If yes, could you point to that way how to do, please?
(0054448)
Zeljan Rikalo (developer)
2011-11-25 12:17

@Fred, yes, there's way to export variable from inside exe, but I don't know exactly how, Vincent mentioned that in some issue few weeks ago afair ... so search in issues :)
(0055540)
Zeljan Rikalo (developer)
2012-01-07 11:22

Please close. This issue is not fixable by lazarus.
You can export LIBOVERLAY_SCROLLBAR=0 or use libc.putenv() (man putenv)
and add LIBOVERLAY_SCROLLBAR=0 to your application.

- Issue History
Date Modified Username Field Change
2011-10-19 16:55 Fred New Issue
2011-10-19 16:55 Fred Widgetset => GTK 2
2011-10-19 19:02 Vincent Snijders LazTarget => -
2011-10-19 19:02 Vincent Snijders Severity block => feature
2011-10-19 19:03 Vincent Snijders Note Added: 0053173
2011-10-19 19:03 Vincent Snijders Status new => acknowledged
2011-11-07 11:02 Fred Note Added: 0053884
2011-11-07 11:38 Fred Note Edited: 0053884
2011-11-07 12:23 Zeljan Rikalo Note Added: 0053887
2011-11-07 12:32 Zeljan Rikalo Note Edited: 0053887
2011-11-07 13:02 Vincent Snijders Relationship added related to 0020618
2011-11-07 15:46 cobines Note Added: 0053893
2011-11-07 16:31 Zeljan Rikalo Note Added: 0053896
2011-11-25 11:26 Fred Note Added: 0054445
2011-11-25 12:17 Zeljan Rikalo Note Added: 0054448
2012-01-07 11:22 Zeljan Rikalo Status acknowledged => resolved
2012-01-07 11:22 Zeljan Rikalo Resolution open => not fixable
2012-01-07 11:22 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-01-07 11:22 Zeljan Rikalo Note Added: 0055540
2012-01-17 09:31 Juha Manninen Relationship added related to 0020679
2012-01-17 09:32 Juha Manninen Relationship deleted related to 0020679
2012-01-17 09:32 Juha Manninen Relationship added has duplicate 0020679
2012-01-17 10:19 Fred Status resolved => closed



MantisBT 1.2.12[^]
Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker